Possible injector failure - again!

Faults and Technical chat for the Kia Niro
Post Reply
Lucydog
Posts: 3
Joined: Tue Jan 23, 2018 11:50 am

Possible injector failure - again!

Post by Lucydog » Tue Jan 23, 2018 11:59 am

I thought The days of the Friday afternoon car were over with the demise of BLMC. Our Nero is 13 months old and so far I suffer from air-conditioning failing because the brackets weren’t attached and therefore the pipework failed, and has needed a new set of injectors because it was running rough. Now back in the workshop because it virtually will not run all, having gone from running rough to being a total disaster area in the space of the 2 miles to get it to the garage, could it be the injectors again? Does anyone have any experience ?


h2onorth
Posts: 152
Joined: Thu Nov 24, 2016 6:19 pm

Re: Possible injector failure - again!

Post by h2onorth » Thu Jan 25, 2018 10:39 am

Hi Lucy dog.Sorry to hear of your woes!. Both the Aircon brackets and fuel injector problem are new to us.
There is a degree of hesitation during the warm up period (worse in cold weather) which is known about and a Engine management software update has reduced it but it's still noticeable. Hope your dealer is a proactiive type with your problems. h2onorth


Lucydog
Posts: 3
Joined: Tue Jan 23, 2018 11:50 am

Re: Possible injector failure - again!

Post by Lucydog » Thu Jan 25, 2018 11:33 am

Cheers for that, they are doing more tests so I’ll keep the post updated


Lucydog
Posts: 3
Joined: Tue Jan 23, 2018 11:50 am

Re: Possible injector failure - again!

Post by Lucydog » Mon Jan 29, 2018 1:48 pm

So apparently need new injectors , a new cat and possibly a gas sensor. Dealer has been good so far but unimpressed with Kia Warranty (no quick decision here) and Kia supply chain, two cats coming to U.K. but they may be spoken for. God knows about the injectors. Learning point is don’t buy new technology from company based the other side of the world who can’t seem to cope
.


wrzoch
Posts: 5
Joined: Mon Aug 27, 2018 6:42 pm

Re: Possible injector failure - again!

Post by wrzoch » Mon Aug 27, 2018 7:39 pm

Hi,

Could you elaborate on this "running rough"?

I've strange feeling that something is wrong with mine Niro too.
I think that there is a petrol in oil (strong gasoline smell and noticed very high oil level before first oil change).
Couple times noticed very strong exhaust gases smell (something like not burnt gasoline, which I could expect from two-stroke, but not from four-stroke direct injection engine).
Engine sound is not right. It is too loud and sounds ... strange. Right after start after the night (even now, when we have more than 10 Celsius over the night) engine works strange on idle, not even.

I've reported this to dealer, they took the car for some diagnosis ... and after over 2 hours of this inspection told that everything is OK.
And this is "the best" KIA dealer in the neighborhood, at least as for servicing/repairs.


h2onorth
Posts: 152
Joined: Thu Nov 24, 2016 6:19 pm

Re: Possible injector failure - again!

Post by h2onorth » Mon Sep 03, 2018 11:28 am

Hi wrzoch.
High oil level is a worry. Did they analyse the fluid to confirm and was the oil changed. Did they change or check sparkplugs?
h2onorth


Mdornbus
Posts: 1
Joined: Wed Nov 27, 2019 7:29 pm

Re: Possible injector failure - again!

Post by Mdornbus » Wed Nov 27, 2019 7:32 pm

Just to let you know I have a 2017 first edition Niro with 49k miles and injector failed. Hope this is not going to be a chronic issue.


Post Reply

Return to “Faults & Technical”