Page 1 of 1

Rough running Niro

Posted: Fri Jul 12, 2019 12:29 pm
by Richardowen
We have had a Kia Niro for two years. All started well but after 6 months the car began to rough run when driving in the 40 to 50 mph (60 to 80KPH) and particularly when going uphill. The dealer has been concerned and is trying to come to grips with the problem. They have replaced all 4 injectors and done an upgrade on the EMS. What we have noticed is that this problem is very noticeable in the cold and particularly after heavy rain. Is there anyone out there who might have an idea what this car is suffering from? I feel that this is definitely an electrical issue probably related to one cable affecting one piston. At the moment my wife is very reluctant to go out for long journeys in a car she absolutely loves but doesn't trust. A great shame KIA.

Re: Rough running Niro

Posted: Mon Jul 15, 2019 7:23 pm
by AlanW55
If Kia with all their sophisticated diagnostic equipment can't solve your problem then it's highly unlikely any of us amateurs will be able to help. I once had a new Ford Orion 1.6i that always run rough until the revs were higher. Ford were unable to solve for over 9 months. They finally agreed to sell me a new one at the original price, and gave me trade-in price equal to the forecourt selling price. The new one was fine. Try that one with Kia, 18 months of problems is totally unacceptable.

Re: Rough running Niro

Posted: Tue Jul 16, 2019 8:29 am
by Richardowen
Thanks for your thoughts and I agree with your comment. The car has just gone back in for a fourth time and we can only hope it produces a problem whilst under diagnosis. It seems strange that we appear to be the only ones with this problem. Thanks for your input.

Re: Rough running Niro

Posted: Tue Jul 16, 2019 8:31 am
by Richardowen
Thanks for your thoughts and I agree with your comment. The car has just gone back in for a fourth time and we can only hope it produces a problem whilst under diagnosis. It seems strange that we appear to be the only one with this problem. Thanks for your input.

Re: Rough running Niro

Posted: Tue Jul 16, 2019 8:56 pm
by AlanW55
Have Kia acknowledged there is a problem? I had a Ford technician drive mine so they couldn't claim there was nothing wrong! I'm not sure if yours is an intermittent problem (the ones that at never show up at the dealers!) but mine was constant. Good luck, keep us posted!

Re: Rough running Niro

Posted: Thu Jul 18, 2019 7:54 pm
by Richardowen
I have at last had an acknowledgement that they have found a problem. It needs a lot of parts and before I expand on what they have discovered, I shall wait until the repairs are done and report back. It could be a surprise in what they have found.